Symptom
The CBO was created with an ID and ID Origin fields to be assigned to a segmentation object using Legacy Mode. However, no ID Origin shows up when you try to select an ID Origin during a new Assignment of Custom Business Object to Segmentation Object on Marketing Extensibility app.
Environment
SAP Marketing Cloud
Reproducing the Issue
- Open "Marketing Extensibility" app.
- Select the option "Assign to Segmentation" under "Custom Business Object" section.
- Click on the plus(+) sign.
- Select your CBO.
- Select the desired Segmentation Object.
- Try to select the "ID Origin" and notice that no field shows up.
Cause
The length of the "ID Origin" field is greater than 20. In order to be available on the ID Origin list during the assignment, the field should have length less than or equal to 20.
Resolution
There are two different approaches depending on the current transport status of the Custom Business Object:
- If the Custom Business Object hasn't been transported yet:
Change the length of the field you want to use as ID Origin on the root node of the Custom Business Object to 20 or less. This is done on the definition of the CBO on "Custom Business Objects" app. After the change, click on Publish and wait for it to finish to confirm the changes.
- If the Custom Business Object has been already transported:
In this case it's not possible to change the old field anymore anymore and you must create a new field with the correct length to use as ID Origin on the root node of the Custom Business Object.
See Also
Keywords
CBO, assign cbo to segmentation , KBA , CEC-MKT-EXT , Marketing extensibility , Problem
Product
Attachments
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