Symptom
Error 'No Authorization to activate view YY9...' while editing a Custom CDS view after 2022 S/4HANA Cloud upgrade.
Environment
S/4HANA Cloud 2202
Reproducing the Issue
1. Open Custom CDS View (To Be Deprecated)
2. Edit a custom CDS View
3. Publish the change
Cause
Since 2022, the old version app Custom CDS Views is Read Only, that's why you get the authorization error.
Please go through below blog to have a better understanding.
https://blogs.sap.com/2022/01/25/custom-cds-views-whats-new-in-2202/
With 2202, the vast majority of Custom CDS views at customers are managed with the new app and we can therefore go one step further and switch the app to a pure display mode.
Resolution
To solve this, please migrate the view to the new app.
1. Open the new version of 'Custom CDS Views'
2. On the right top, there is a Migrate Views button
3. Simply click on that button and select the desired views to migrate to this new app.
See Also
Migration-Custom CDS Views – What’s New in 2005
Custom CDS Views – What’s New in 2202
2874206 - Custom CDS Views - New App Version
Keywords
KBA , BC-SRV-APS-GKE , Generic CDS Key User Editor , Problem