Symptom
While accessing the Adaptation Mode the queries "Opportunity Sales Team" - "Assigned to Department" - "Account Team" are set as visible, but from the User's View they are not visible.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open the Visit Work center.
- Go to Route View
- Click at New.
- At Quick Create screen select Owner OVS (object value selector) field.
- Select the advanced search.
- Open the adaptation mode.
- Select the Queries presented in the Implementation layer.
- Notice that 3 queries are hidden: "Opportunity Sales Team" - "Assigned to Department" - "Account Team".
Cause
The visibility of the queries (default sets) in the Employee OVS (/BYD_COD/SalesOnDemand/Employee/UI/COD_Employees.OVS.uicomponent) depend from the import parameter filled by the corresponding consumers:
- If the import parameter OpportunityUUID is filled the query "Opportunity Sales Team" gets visible.
- If the import parameter AssignedToOrgUnitUUID is filled the query "Assigned to Department" gets visible.
- If the import parameter AccountUUID is filled the query "Account Team" gets visible.
Resolution
In the Route Quick Create screen, in case none of these import parameters is set therefore the three queries will be invisible and cannot be set to visible via adaptation (KUT/flex).
Keywords
Opportunity Sales Team; Assigned to Department; Account Team; , KBA , LOD-CRM-EMP , Employee , How To
SAP Knowledge Base Article - Public