Symptom
When users are navigating from BizX to Learning they face the following error:
- Failed to authenticate the SAML response. If this keeps happening please contact the administrator.
Environment
- SAP SuccessFactors HXM Suite - All Supported Versions
- SAP SuccessFactors Learning - All Supported Versions
Reproducing the Issue
- Go to the BizX home page >
- Click the menu drop-down >
- Click the "Learning" entry >
- The user will be redirected to the Learning module >
- The SAML error will be displayed:
- Failed to authenticate the SAML response. If this keeps happening please contact the administrator.
Cause
This issue can occur due to different scenarios:
- This error message is related to the browser's cookies, which are being blocked.
- The option "Enable SuccessFactors Learning third-party cookie mechanism" may not be flagged in the BizX provisioning area.
- The user was not synchronized from BizX to Learning.
Resolution
- If the browser's cookies are being blocked, try checking the KBA 2087462 - How to delete browsing history and cache/cookies of an internet browser.
- The option "Enable SuccessFactors Learning third-party cookie mechanism" can also avoid the above-mentioned error. If desired, please, create a case under the "LOD-SF-LMS-INT" component asking to the processor to check it in the BizX provisioning area, with your written permission to us to perform it and informing the related BizX ID. More details can be found at the KBA 2874083 - Enable SuccessFactors Learning third-party cookie mechanism - What does it mean - [Learning].
- Even if the user exists in both BizX and Learning, make sure that it is synchronized through the connector:
- Go to the Learning admin side > System Administration > Connectors >
- Select the connector ("User Connector" or "User Connector - SF") >
- Check the FPT connection by pressing the "Test FTP Connection" button >
- If it shows "Failed" a status, check the SFTP configuration >
- Check if the connector is successfully running >
- If there are errors when running the connectors, check the connector configuration.
See Also
2087462 - How to delete browsing history and cache/cookies of an internet browser
2185696 - Failed to Authenticate SAML Response - LMS from BizX - Safari Browser
Keywords
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