Symptom
- You are using "Adapt UI"
- You want to add/edit/delete a field in the UI.
- You are getting error message "Sorry, a technical error occurred. Please try again later, or contact your administrator."
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to the Me Area
- Click on Adapt UI
- Add/edit/delete a field
- Try to save the changes
Error: "Sorry, a technical error occurred. Please try again later, or contact your administrator."
Cause
You are probably trying to adapt the UI in the productive system but there are already changes in the productive system that were transported from the quality system.
Resolution
In general, it's recommended that you make your UI changes in a test system and transport them to the productive system. If you don't have or don't use a test system, it's also fine to do everything in the productive system. However, do not mix these scenarios for one app: Either, perform all UI adaptation actions for an app only in the productive system, or perform them only in the test system (and transport the changes to the productive system from there each time). Mixing scenarios can lead to severe UI adaptation conflicts.
See Also
Keywords
Adapt UI, Key User Adaptation, Adapting the UI, add, edit, delete, field, technical error occurred, contact your administrator, extensibility, custom field , KBA , CA-UI5-FL , Flexibility Infrastructure , Problem