SAP Knowledge Base Article - Public

3150696 - Error "App could not be opened either due to an incorrect SAP Fiori launchpad configuration or a missing role assignment"

Symptom

When creating a service order by clicking the "Create" button under the "Create Service Order" drop-down list in the "Manage Service Orders" app, an error occurs: "App could not be opened either due to an incorrect SAP Fiori launchpad configuration or a missing role assignment".

Environment

SAP S/4HANA Cloud

Reproducing the Issue

  1. Open the "Manage Service Orders" app.
  2. Click the "Create Service Order" drop-down list and select "Create".
  3. Select one service order type.
  4. The error occurs: "App could not be opened either due to an incorrect SAP Fiori launchpad configuration or a missing role assignment". The detail information of this error is: "Failed to resolve navigation target "#ServiceOrder-create?sap-app-origin-hint=&sap-processtype=SVO1". This is most likely caused by an incorrect SAP Fiori launchpad content configuration or by a missing role assignment".

Cause

None of the business roles assigned to the business user is assigned with the business catalog "SAP_CRM_BC_SERV_PROCORDER_PC" (Service - Process Service Order).

Resolution

Please assign the business catalog "SAP_CRM_BC_SERV_PROCORDER_PC" (Service - Process Service Order) to one of the business roles assigned to the business user following the below detailed steps:

  1. Go to the "Maintain Business Users" app and find the business user.
  2. Search for the business role, e.g. "RIHO_CUSTOMER_SRVC_MGR" (Customer Service Manager) under the "ASSIGNED BUSINESS ROLES" tab and click into it.
  3. In edit mode, click the "Add" button and search for the business catalog "SAP_CRM_BC_SERV_PROCORDER_PC" (Service - Process Service Order) under the "Assigned Business Catalogs" tab. 
  4. Click "Apply".

Keywords

Manage Service Orders, Create Service Order, Incorrect, Fiori Launchpad Configuration, Missing Role Assignment, ServiceOrder-create?sap-app-origin-hint=&sap-processtype=SVO1, SAP_CRM_BC_SERV_PROCORDER_PC, Maintain Business Users, ASSIGNED BUSINESS ROLES, RIHO_CUSTOMER_SRVC_MGR , KBA , CRM-S4-SRV-SVO , S4CRM: Service Order , Problem

Product

SAP S/4HANA Cloud 2202