Symptom
FTP transfer using interface.us.wfs.cloud server failed with the below error.
Environment
- SAP Time and Attendance Management by WorkForce Software
- SAP Boomi
Reproducing the Issue
- Boomi job that checks the SFTP every five minutes to pull down files.
- Timeout error will be seen on the screen for failed SFTP
Cause
Workforce has default setings as follows for SFTP
===============================
LoginGraceTime = 2 minutes
ClientAliveInterval = 0 minutes
ClientAliveCountMax = 3 minutes
There is a limit of 10 connections at a time per login.
Resolution
Open less number of connection as per the default settings.
NOTE:- If needs more connection, this needs to be done as a service request by Workforce as this is customer specific.
Ticket should be opened with component 'xx-part-wfr-srv' which will be forwarded directly to workforce. Kindly note that this request might be billable.
See Also
Keywords
BOOMI, SFTP, Workforce server, Job failed, timeout, LoginGraceTime, ClientAliveInterval, ClientAliveCountMax, connections limit, TAM , KBA , XX-PART-WFR-TAM , SAP Time and Attendance Management by Workforce Software , Problem