SAP Knowledge Base Article - Public

3151658 - When You Change the Main Address of an Account, the Previous Phone Number is Not Copied to the New Main Address

Symptom

You have noticed that if you change the main Address of an Account (from an Address with Phone Number to another without a Phone Number), the Phone Number is not copied to the new main Address.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Customers Workcenter.
  2. Navigate to Accounts view.
  3. Open any Account.
  4. Go to Address facet and click "Edit".
  5. Change the Main address with Phone Number to another without a Phone Number.
  6. The Phone number is not copied to main address.

Cause

The expectation that Communication Data is copied from any Address to the main Address is wrong in the SAP Standard product.

In General, the Communication Data maintained at a specific Address belongs to that Address. For that reason, there will not be a copy of Communication Data when changing the default Address.

Resolution

This is the current system behavior.

If this functionality is needed in your system, we would recommend the PDI Community (https://community.sap.com/topics/cloud-applications-studio) where you can meet many ABSL Developers from both SAP and Partner Environments who are willing to help in such queries.

Keywords

Communication data ; Address ; Account ; Default ; Main ; Phone , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer add-ins all versions