Symptom
When some specific user (or users from some specific business role) tries to access the Import screen in Data Workbench work center this error is shown:
Error fetching data. Create an SAP case.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Logon to C4C.
- Go to Data Workbench work center.
- Go to Import view.
- Error: Error fetching data. Create an SAP case.
Cause
This user (or business role) has no access to the Monitor view.
Resolution
Assign the Monitor view to affected users or business role.
- Go to the Administrator work center
- Access the Business Users work center view
- Select a user and click the Edit button, then select the Access Rights option.
- Navigate to the Work Center and View Assignment tab.
- Find and expand view COD_DATALOADER_WCF.
- Assign the Monitor view.
- Click in Save button.
See Also
If this error message is happening for all users in the system (including Key User) an case should be raised to SAP Support.
Keywords
Error fetching data, Data Workbench, Import , KBA , LOD-CRM-INT-API , OData API (C4C Only) , LOD-CRM-INT-DWB , Data Workbench , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2202