Symptom
Image/Data is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
- Business would like to use the Business Object (BO) property "Assigned to" from tickets
- When trying to create a custom OData Service, the administrator is unable to find the "AssignedTo" property under the Service Request BO
- Per the "Service Request" online help, the property is be exposed, therefore available, but the user is unable to locate it
Environment
- SAP Cloud for Customers
- SAP Cloud for Service
Reproducing the Issue
- Go to the Administrator work center, in OData Service Explorer view.
- Select the filter Custom OData Service.
- Add a new entry and name it something like "Z_ServiceRequest"
- Expand the root node for the BO Service Request
- Cannot find the field "AssignedTo"
Cause
Assigned to property is not stored in Root node of service request BO. It is stored in Party Node.
Resolution
- Go to the OData Service Explorer
- Open the custom OData Service created and edit or create a new one
- Under Root, navigate to "ProcessorParty" -> PartyKey
- Select PartyID, as seen from the below example screenshot
See Also
Keywords
Odata Services Assigned To AssignedTo , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2202