SAP Knowledge Base Article - Public

3152111 - Odata Service Standard field "Assigned to" for Service Request BO is not found in the Odata Service Explorer

Symptom

Image/Data is from SAP internal systems, sample data, or demo systems.  Any resemblance to real data is purely coincidental.

  • Business would like to use the Business Object (BO) property "Assigned to" from tickets.
    AssignedTo_ticket.png
  • When  trying to create a custom OData Service, the administrator is unable to find the "AssignedTo" property under the Service Request BO.
  • Per the "Service Request" online help, the property is be exposed, therefore available, but the user is unable to locate it.

Environment

  • SAP Cloud for Customers
  • SAP Cloud for Service

Reproducing the Issue

  1. Go to the Administrator work center, in OData Service Explorer view.
  2. Select the filter Custom OData Service.
  3. Add a new entry and name it something like "Z_ServiceRequest".
  4. Expand the root node for the BO Service Request.
  5. Cannot find the field "Assigned to".

Cause

Assigned to property is not stored in Root node of service request BO. It is stored in Party Node.

Resolution

  1. Go to the OData Service Explorer.
  2. Open the custom OData Service created and edit or create a new one.
  3. Under Root, navigate to ProcessorParty -> PartyKey.
  4. Select PartyID as seen from the below example screenshot.
    PartyID.png

See Also

  • KBA 2713787 - How to Add AccountName to Custom OData Service Based on Opportunity Collection
  • KBA 2842090 - Frequently Asked Questions on Custom OData Services

Keywords

 Odata Services Assigned To AssignedTo , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer core applications all versions