SAP Knowledge Base Article - Public

3152129 - Error message "Sending e-mail is not possible, no sender available" is shown

Symptom

When trying to send an e-mail from an object (for example, Sales Quote) to an Employee, system shows error message "Sending e-mail is not possible, no sender available.". This behavior occurs to any user.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customer work center.
  2. Go to the desired Business Object view (Sales Quote for example).
  3. Open object ABC (ABC represents the number ID).
  4. On E-Mail section click New.
  5. Enter the title, body and the e-mail for the recipient.
  6. Click on Send.

The error message "Sending e-mail is not possible, no sender available" and "Save Failed" will be displayed.

Cause

In E-mail and Fax Settings activity, under E-Mail and Fax Delivery in a Non-Productive System, the option 'Send all e-mails to this address' is selected but no e-mail address is maintained.

Resolution

This is the expected system behavior.

To correct it, follow the path below:

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects work view.
  3. Click on Open Activity List.
  4. Search and click on the activity E-mail and Fax Settings.
  5. Click on E-mail and Fax Settings.
  6. Under 'E-Mail and Fax Delivery in a Non-Productive System', either choose option 'Send all e-mails to business partners' or select 'Send all e-mails to this address' with a valid e-mail address maintained.

Keywords

Contact, Account, Inidvidual Customer, Campaign, Sales Order, Opportunity, Lead, Ticket , KBA , LOD-CRM-ACT , Activities , LOD-CRM-SC-EML , Email , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-ACC , Account , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions