Symptom
When trying to send an e-mail from an object (for example, Sales Quote) to an Employee, system shows error message "Sending e-mail is not possible, no sender available.". This behavior occurs to any user.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customer work center.
- Go to the desired Business Object view (Sales Quote for example).
- Open object ABC (ABC represents the number ID).
- On E-Mail section click New.
- Enter the title, body and the e-mail for the recipient.
- Click on Send.
The error message "Sending e-mail is not possible, no sender available" and "Save Failed" will be displayed.
Cause
In E-mail and Fax Settings activity, under E-Mail and Fax Delivery in a Non-Productive System, the option 'Send all e-mails to this address' is selected but no e-mail address is maintained.
Resolution
This is the expected system behavior.
To correct it, follow the path below:
- Go to the Business Configuration work center.
- Go to the Implementation Projects work view.
- Click on Open Activity List.
- Search and click on the activity E-mail and Fax Settings.
- Click on E-mail and Fax Settings.
- Under 'E-Mail and Fax Delivery in a Non-Productive System', either choose option 'Send all e-mails to business partners' or select 'Send all e-mails to this address' with a valid e-mail address maintained.
Keywords
Contact, Account, Inidvidual Customer, Campaign, Sales Order, Opportunity, Lead, Ticket , KBA , LOD-CRM-ACT , Activities , LOD-CRM-ACC , Account , LOD-LE-CQP , Customer Quote Processing , LOD-CRM-SC-EML , Email , Problem