Symptom
SAP SuccessFactors Work Zone configurator shows error at company creation step .
Environment
SAP SuccessFactors Work Zone
SAP Jam Collaboration
Reproducing the Issue
- Start the SAP SuccessFactors Work Zone configurator for a new Work Zone tenant setup.
- Choose to create new tenant by selecting option "Create a new SAP SuccessFactors Work Zone tenant".
- Provide SuccessFactors instance details in Step 2.
- Click "Trigger Setup" in Step 3: Set Up Environment
- Error shown - "createCompany, Unprocessable Entity"
Cause
The issue is due to existing SAP Jam tenant matching the same BizX Company ID entered in Step 2: Create a Destination to SAP SuccessFactors. Since this is supposed to be a unique attribute across tenants, the configurator fails to create a new tenant with that same company id and throws error.
Resolution
There are two options to handle this situation->
- Use the existing SAP Jam tenant by switching to the option "Create an SAP SuccessFactors Work Zone tenant based on your existing SAP Jam tenant" in the configurator. For this, the pre-requisites mentioned in the guide need to be first met for this existing tenant-> Run the Work Zone Configurator - SAP Help Portal
It involves raising Support tickets, and also some manual configuration work on your end.
OR, - If the existing Jam tenant is not actually in use, and does not have any data that needs to be carried over to Work Zone, then it is better to go with the New Tenant option since that will involve much less manual work. In this case, to address the error in the configurator, SAP Jam support team can update the BizX Company Id associated with the existing Jam instance- change it slightly (say, from "ABC" to "ABC_Disabled") so it no longer conflicts with the new tenant creation by the configurator.
Please raise a ticket to LOD-SF-JAM-SWZ component to get this done. The ticket should have the following title/subject- "Create Company error in SAP SuccessFactors Work Zone configurator - <Add_BizX_Company_Id>"
And the following in description:
- A reference to this KBA
- BizX Company Id for which the error came up
- BizX Data Center
Once support updates the existing tenant, retry the "Trigger Setup" option in the Step 3 of the configurator. It should be able to proceed successfully.
Following that, please ask support to purge the old Jam tenant and provide your written approval for the same.
Note for Support: Please check the Internal Memo section of this KBA to find the steps needed from Support end.
Keywords
KBA , LOD-SF-JAM-SWZ , Collaboration Features , Problem
Product
SAP Jam Collaboration all versions ; SAP SuccessFactors Work Zone all versions
Attachments
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