SAP Knowledge Base Article - Public

3152545 - Advanced Search for Accounts Field External ID Brings Unexpected Results

Symptom

You are using advanced search for accounts, filtering records based in External ID field. Your search criteria brings what seem to be wrong results.

Environment

 SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center;
  2. Open the Accounts work center view;
  3. Open Advanced Search;
  4. Enter 123 in the External ID field (where 123 is the External ID of an account);

You notice an account with 456 (where 456 is the External ID) displayed in the list.

Cause

In the view Mapping for Integration of the account there is a relationship maintained which is flagged as 'Main' and which has External ID is 456.

Resolution

  1. Go to the Customers work center;
  2. Open the Accounts work center view;
  3. Open Account ABC (where ABC is the account you tried to locate in step 4 of 'Reproducing issue');
  4. Open the Mapping for Integration view (you might need to add this via Adaptation Mode);
  5. You will see an entry 456 (where 456 is the External ID) in the relationship flagged as 'main' (you might need to add the column 'Main' via adaptation mode, too). 

The External ID in account advanced search will always bring the default External ID mapped in the view Mapping for Integration.

Keywords

External ID ; Accounts ; Advanced Search ; Filter ; Mapping for Integration ; Account ID ; , KBA , LOD-CRM-ACC , Account , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions