SAP Knowledge Base Article - Public

3152596 - Not Possible to Add Status Field in Opportunity Header

Symptom

You are trying to add field Status in Opportunity header, however, the field is grayed out.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Sales Workcenter.
  2. Open Opportunities view.
  3. Open any Opportunity.
  4. Start Adaptation mode.
  5. You will see that field Status is set to visible, however, the field is not visible on the UI.

Cause

If you have custom statuses defined for your Opportunity in the Business Configuration Fine-Tuning Activity Opportunity, "Maintain Custom Status" hyperlink, then the system will not allow you to maintain the standard Status and control the actions related to it.

For a simpler explanation: if the document type related to the Opportunity is using Custom Status or if it has a custom status assigned, then you have to use custom Status only. You cannot use the actions related to standard Opportunity statuses. Even though system shows the field, it will not allow you add it to the layout for the same.

Resolution

This the expected system behavior when using custom statuses.

If you want to return to using standard opportunity statuses, you will need to delete all instances in the system that use this status first.

Alternatively, you can create a new document type and NOT set any custom status for this.

See Also

 KBA 2637296 - Opportunity "Set as [Status]" Missing in Actions Button

Keywords

Status ; Header ; Adaptation ; Grayed out ; Add ; Custom , KBA , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions