Symptom
- The birthday and work anniversary cards are not displaying in latest Homepage.
- The Birthday and Work Anniversary cards in For You Today section are showing blank, without any detail.
- Birthday cards not displayed right after the job runs due to manager's time zone.
- What are the permissions to see the anniversary cards on the Latest Homepage?
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors HCM Suite
Reproducing the Issue
Manager goes to the Latest Home Page and see that the Birthday and Work Anniversary cards of their direct reports are not appearing.
Cause
The majority of issues related to birthday and anniversary are related to the wrong configuration of the steps bellow. Carefully read and apply all steps provided in the Resolution section of this KBA.
The Birthday and Work Anniversary cards visibility in latest Homepage is controlled by permission on standard elements. Birthday card data is read from dataOfBirth and Work Anniversary card data is read from serviceDate (if configured in data model) or hireDate.
- Possible cause #1: The standard elements as below are not configured in data model.
- Standard element dateOfBirth
- Standard element serviceDate or hireDate
- Possible cause #2: If the standard elements above are configured in data model, the below permissions are not granted to managers.
- Employee Data → Manager
- Employee Data → Date Of Birth
- Employee Data → Service Date or Hire Date (The field level permissions need to be enabled according to the element configured in data model. For instance, the service date permission should be enabled if service date is configured in data model, the hire date permission should be enable if hire date is configured in data model. At least one of them should be configured in data model and the service date will be checked first.)
- User Search
Resolution
If the instance has both service date and hire date configured in data model than service date will take preference and data should be populated/present for Service date in order to view the Work anniversary card.
We can verify whether Service date and Date of birth is present or not using "Export Extended User Information -> Personal Information" export.
Hire Date can be verified via Employee export (Check reference KBA 3165090)
If Service date, Date of birth or Hire Date is not configured, please follow below steps to add them.
1. Please ensure below standard elements are configured in data model.
- Standard element dateOfBirth
- Standard element serviceDate or hireDate
2. Please ensure below permissions are granted to managers:
The permission is controlled by the field level permission on these fields. Please ensure they're granted to managers and their direct reports are configured in target population.
- Go to Admin Center
- Manage Permission Roles
- Configure below field level permissions for the permission role. (The permission name might be different according to the label configured in data model)
- Employee Data → Manager
- Employee Data → Date Of Birth
- Employee Data → Service Date or Hire Date
- Please also make sure the user also has User Search permission.
If the manager is seeing a blank pop up when opening the birthday card, go to User Role Search, check what roles are giving the user "Manager" permission, open the roles and see if the target population is set to "All(Employees)(exclude Granted User from having the permission access to him/herself)". If so, this is the cause of the issue.
Consider following one of the below steps:
- In the target population assignment, uncheck the option "Exclude granted users from having permission access to themselves."
- Alternatively, create a new role that allows the assignment of only "Employee Data > Employee Profile > Manager" to the logged-in user
Please consider the following notes:
- The admin who had triggered the Push Birthday and Anniversary Cards on the Latest Home Page upgrade will be used as the Job owner for both jobs. If this user becomes inactive at any point the jobs will need to be updated to an active user.
- The change in data model, permission and dates will not reflected on the latest home page immediately. It takes effect in the first day of next month for the monthly card and next day for the daily card. If you want to see the change immediately, you have to trigger the job manually by logging into provisioning, navigating to Manage Scheduled Jobs and clicking Run It Now on the specific job. The job named "Push Date of Birth and Anniversary Data for Cards on Latest Home Page (Daily)" is used for the daily card, and the job named "Push Date of Birth and Anniversary Data for Cards on Latest Home Page (Monthly)" is used for the monthly card.
- The daily birthday job will only generate birthday cards for those whose birthday is the next day of UTC time. However, the display time of this card will be according to the time zone of the manager. We may not see the card immediately after we run the job. Please ensure to check the cards are showing based on manager's time zone.
- Please ensure that data exists in dataOfBirth and serviceDate/hireDate and ensure default standard element dateOfBirth and serviceDate/hireDate is being enabled and used . If there is no data, the birthday card or work anniversary card won't be displayed.
- The legacy home page gets data from EC (HRIS element) while the latest home page gets data from User standard element which supports both EC and Non-EC customers. It is possible that customer can see the card on legacy home page but cannot see the card on latest home page.
- The display time of the card will be based on the manager's time zone. You may not see the card immediately after the job runs.
The daily birthday job will generate birthday cards for those whose birthday is the next day of UTC time. However, the display time of this card will be according to the time zone of the manager.
For instance, the manager's time zone is UTC+10, so please follow the below example which describes the process:- June 10, 2022, 11:00 AM (UTC+10): Run the birthday job, the system will generate birthday cards for users whose birthday is June 11.
- June 11, 2022, 00:01 AM(UTC+10). the manager should be able to see.
- Notice that the card will be expired the next day which is also based on the manager's time zone.
- Birthday and Work Anniversary Cards will display birthday names of the day considering data model "dateOfBirth" and "hireDate" to theirs specific manager as per permission roles, hence, there is no option to filter or sort it between FTE (Full Time Employee) and Contingent Workers.
- For the direct reportee for whom the manager is changed to another manager, currently the previous manager will see the card although it is not clickable until the next month. Meanwhile, the new manager will also receive the clickable card in the same month after push job triggered. This is expected behaviour currently.
- Birthday reminders or anniversary cards are generated at the beginning of each month. If employee information changes in the middle of the month and the task is run again, the original cards will be updated. However, there is an exception. If all employees in the cards generated for a manager at the beginning of the month have left the company or moved under a new manager, and none of his/her subordinates has qualified events this month now, no new cards will be generated for that manager, and the cards generated at the beginning of the month will not be updated either. In this case, the cards that users see will still be the old ones, and employees who have left will still be displayed on the cards.
See Also
Keywords
birthday and work anniversary cards, dataOfBirth, serviceDate, hireDate, permission, standard element, data model, anniversary cards latest home page, permissions anniversary cards, time zone, birthday card time zone, timezone, manager time zone, homepage , KBA , LOD-SF-PLT-LHOM , Latest Home Page , Problem