Symptom
Email address is not populated into Email 'To' field from Lead for Individual Customer.
Environment
SAP Cloud for Customer.
Reproducing the Issue
- Go to Sales work center.
- Go to Leads view.
- Open the lead XYZ (where XYZ denotes the Lead ID).
- Go to Activities facet.
- Select E-mail activity.
- Select New to create e-mail activity.
The e-mail address is not auto populated in "To" field.
Cause
It is currently not possible for the email address of the individual customer to be picked up.
The only scenario where the email address is picked up is for a contact, whose communication data as well as the relationships with accounts are maintained in a consistent manner.
This is done for historical reasons and it is expected to behave in this manner.
Resolution
Currently you can manually select the email address in the field and create an e-mail activity.
Keywords
To field, Individual Customer e-mail address, Lead e-mail activity. , KBA , LOD-CRM-SC-EML , Email , Problem