SAP Knowledge Base Article - Public

3153296 - "Apply Planned Time" does not show up in New Time Sheet UI.

Symptom

There is no "Apply Planned Time" shown in the New Time Sheet UI as in below screenshot. 

But it is expected to have the "Apply Planned Time" button on the top-right corner as below.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Employee Central

Reproducing the Issue

Navigate to the Time Sheet UI of an employee and there is no 'Apply Planned Time' button.

Cause

This may happen due to any of below reasons.

  • The employee's Time Recording Profile is Negative in Time Recording Method.
  • The employee's Time Recording Profile is Positive in Time Recording Method, but the Main Attendance Time Type in the employee's Time Profile is set as Enabled in employee self-service scenario = No.
  • The employee's Time Recording Profile is Postive in Time Recording Method, but there is Clock In Clock Out Group maintained in the employee's Job Information.

Resolution

Please make sure the employee's assigned Time Recording Profile is Positive. 

In other words, the relevant Time Recording Profile's Time Recording Method should be Positive.

And at the same time, the time type set as the Main Attendance Time Type in the Time Profile needs to have Enabled in employee self-service scenario set as Yes. 

And the employee should NOT have Clock In Clock Out Group configured in Job Information either. In other words, this employee should not use Clock In Clock Out.

See Also

New Time Sheet UI

Keywords

TMS, work, schedule, employee, file , KBA , LOD-SF-EC-TMS , Time Sheet , Problem

Product

SAP SuccessFactors Employee Central all versions