Symptom
When a column is selected to be filtered on, in Detailed Reporting > Manage Filters, and a custom string is entered in the text box of 'Custom Filters', clicking 'OK' DOES NOT work.
Environment
- SAP SuccessFactors HCM Suite
- Analytics & Reporting(Ad Hoc, YouCalc, Canvas / ORD)
- Online Report Designer
- Analytics & Reporting(Ad Hoc, YouCalc, Canvas / ORD)
Reproducing the Issue
- Login into instance
- Edit any existing Detailed report
- Click on Manage Filters
- Select a column and click on Custom Filter tab in the Filter Designer window
- Try to apply a Dynamic filter and Click on OK
- You will notice that OK button doesn't work
Cause
When we click on a field inside 'Manage Filters' an API call will be sent to fetch all the unique values present under that particular field. If the number of values are huge this API call will takes more time. During this time, where the server is processing the API Call, if we try to apply custom filter on that field, the OK button does not work and the page gets stuck.
Resolution
Engineering team has made a change in the application behavior by restricting the API call to trigger ONLY when "Report Values" tab is selected in the Filter Designer.
Going forward, customer can apply Custom filter without any issues as no API call is triggered upon selection of the column.
But if customer first clicks on 'Report Values' tab an API call will be invoked and you will have to wait until all the values get loaded before applying any filter under Custom Filter section.
Keywords
Custom, Manage, Filter, Detailed, Reporting, Report, Values, API, Invoke, ORD, OK, Dynamic , KBA , LOD-SF-ANA-ORD , Online Report Designer , Problem
Product
Attachments
Pasted image.png |