Symptom
- When a user performs a Code List Upload, there is no progress or failure of the job and it remains as stuck for some time.
- Other users might not have this issue and might be able to perform the upload successfully, although they have the same access rights
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Business Configuration
- Go to Upload Code List
- Select the Upload Code List link
- Select the relevant Code List Mapping group
- Select Upload and upload your file
- The message 'Run to Create Code List and Mappings is started. Please check Run logs' appears
- But when selecting the Application Log, there is no Application Log ID or further information
Cause
The issue might be caused by the logon language of the affected user.
The Upload Code List job fails, since the logon language of the user is not installed in the system
Example:
- The logon language of a user is DE, and DE (German) as logon language is not installed in the system. This user will not be able to upload the code list.
- the logon language of another user is EN, and EN (English) as logon language is installed in the system. This user will be able to upload the code list.
Resolution
Change the user's language to one of the installed languages in the system to avoid further failures.
Keywords
codelist not possible unable not able stuck hours fails ended ends failed may work fine , KBA , codelist , codelist stuck , SRD-CC-IAM , Identity & Access Management , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions