SAP Knowledge Base Article - Public

3153799 - Upload Code List not Possible

Symptom

When a Code List Upload, the job gets stuck without any progress or failure indication. This issue is not experienced by all users, even if they have the same access rights.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Business Configuration work center
  2. Go to Upload Code List view
  3. Select the Upload Code List link
  4. Select the relevant Code List Mapping group 
  5. Select Upload and upload your file
  6. The message 'Run to Create Code List and Mappings is started. Please check Run logs' appears
  7. However when selecting the Application Log, there is no Application Log ID or further information

Cause

The issue might be caused by the logon language of the affected user.

The Upload Code List job fails, since the logon language of the user is  not installed in the system

Example:

  • The logon language of a user is DE, and DE (German) as logon language is not installed in the system. This user will not be able to upload the code list.
  • the logon language of another user is EN, and EN (English) as logon language is installed in the system. This user will be able to upload the code list.

Resolution

Change the user's language to one of the installed languages in the system to avoid further failures.

  1. Search tenant URL
  2. Enter User ID and Password
  3. In Language field select the installed language 

Keywords

codelist not possible,stuck hours , fails, upload code list , KBA , codelist , codelist stuck , SRD-CC-IAM , Identity & Access Management , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions