SAP Knowledge Base Article - Public

3154200 - Fail to sync data from SF BizX to People Connection (PLM) System - Career Explorer

Symptom

Fail to sync data from SF BizX to People Connection (PLM) System.

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors People Connection
  • SAP SuccessFactors Career Explorer

Reproducing the Issue

  1. Go to Admin Center > Manage People Connection Integration;
  2. Receive error message: API key “<KEY>” does not exist in company “<Customer Bizx CompanyID>”:

cid3300078641*image001.png@01D828D2.C0B94480

Cause

API key does not exist in company, so PLM is not able to use the invalid key to generate token, and then it will cause "401 Error" while calling SF BizX API to sync data.

It is probably caused by instance refresh, as the original API key is lost during instance refresh.

Resolution

To generate a new API key and fix this sync issue, follow below steps:

  1. Go to Admin Center > Manage People Connection Integration > Change the Settings:

    cid3300078641*image002.png@01D828D2.C0B94480

  2. Click edit configuration button, and save the page again:

    cid3300078641*image003.png@01D828D2.C0B94480

  3. This action will refresh and generate new API key for data sync.

Keywords

PLM, People Like Me, People Connection, Career Explorer, error, 401, Unexpected response when requesting tenant token for <Customer Bizx CompanyID> from Container with NAT IP: <NAT IP of container> - 401 - <Error Message>, API key “<KEY>” does not exist in company “<Customer Bizx CompanyID>” , KBA , LOD-SF-CDP-CE , Career Explorer , Problem

Product

SAP SuccessFactors Succession & Development