Symptom
Suppose if a user runs a report created on a module (eg: Performance Management) having huge amount of data, reports are getting timed out user runs them in online/offline.
This happens even when we apply filter on a single user or a template.
Environment
- SAP SuccessFactors HXM Suite
- Analytics & Reporting(Ad Hoc, YouCalc, Canvas / ORD)
- Adhoc Reports & Report Builder
- Analytics & Reporting(Ad Hoc, YouCalc, Canvas / ORD)
Reproducing the Issue
- Login into instance
- Create a simple adhoc report on a domain (eg : PM)
- Select some columns
- Single data set and
- Apply filter on a single user or document id and
- Click on preview
- Report keeps on loading till 5 minutes and
- Later it gets timed out
Cause
Why timeout issue still happen when filters are added on even a single user and template :
Whenever we run a report on a particular domain, first the query related to particular module on which report is created will get executed and on this the filters applied by reporting frame work will get executed, that means no matter what filters are added, the query still needs to execute first the whole joined tables related to module and the filters will only be applied in the last, and if this module has huge amount of data then this query related to module takes more time and timeout exception will occur.
Resolution
Only possible workaround available now is to Schedule AdHoc report and run this schedule whenever required.
Keywords
Time, Out, Huge, Amount, Data, Performance, management, report, module, Filters, query, joins, Table, Adhoc , KBA , LOD-SF-ANA-ADH , Adhoc Reports & Report Builder , LOD-SF-ANA-ORD , Online Report Designer , Problem