SAP Knowledge Base Article - Public

3154575 - The wrong countries appear in the Contact Search Result when you filter by Country.

Symptom

When you search in the Contact OWL for country/regions, for example for country codes  AT and DE, you also get results for other country/regions. For example you get Azerbaijan and Italy as results.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work center
  2. Go to the Contacts view
  3. Go to the Advanced Search
  4. Filter the country/region field with: AT and DE (as example)
  5. Observe: The result list shows further countries such as: Azerbaijan, Italy (as example)

Cause

Contacts in the wrong country/region have multiple "is contact person for" relationships with an AT address. Open the contact and check the Relationships tab and the Address column.

The search is performed in all "is contact person for" relationships via the contact owl country/region advanced find field. Thus these contacts are found while searching for AT.

Resolution

Add the field "main account" to the advanced find and set it to true if you only want to search in the default "is contact person for" relationship.

Keywords

Advanced search, Contact, country/region, Relationship, Address , KBA , LOD-CRM-CON , Contact , Problem

Product

SAP Cloud for Customer add-ins all versions