Symptom
When adding contacts to target groups, you noticed in adaptation mode the fields Related to Me, Related to and Relationship Role, however, you cannot make them visible.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Open the Sales Campaign work center.
- Open the Target Groups view.
- Open Target Group ABC (where ABC is the ID of the target group).
- Open the Members view.
- Click in the Add button and select the Add Contacts option.
- Open the Adaptation Mode.
- Right-click in the Contacts section.
You notice the fields 'Related to Me', 'Related to' and 'Relationship Role' with the flags 'Personalize' and 'Set as Visible' set but they do not appear in the section. You wonder what logic it has behind it.
Cause
These fields are not relevant for this screen, they have no value to be displayed at all. They are not designed/meant/relevant to the target group scenario in the context of doing a search.
Resolution
These fields will be removed from the adaptation mode option in a future release to avoid any misunderstanding.
Keywords
Target Group ; Add Contacts ; Members ; Related to Me; Related to ; Relationship Role ; Adaptation Mode ; KUT ; Search ; , KBA , LOD-CRM-MKT-TG , Target Groups , How To