SAP Knowledge Base Article - Public

3155728 - Report Sales Order History for a Product and Account Shows No Data

Symptom

 You want to use the report Sales Order History for a Product and Account but it shows no results when you run it.

Environment

SAP Cloud For Customer

Reproducing the Issue

1. Go to the Business Analytics Work Center.
2. Go to Design Reports and search for the report Sales Order History for a Product and Account "CODCRMCOV_Q0001".
3. Run the report and you will see the messages "No data found" and "No report data available to display; check the selection".

Cause

The report data is relevant only when account, product and sales area data is provided in the filter.

Please note that, only the completed sales orders (and not canceled) with the sales area as filtered where the mentioned product was ordered will come in report result.

Resolution

Add relevant account, product and sales area data in the filter.

Keywords

CODCRMCOV_Q0001, No data found" and "No report data available to display; check the selection, , KBA , AP-RC-ANA , C4C, ByD, Travel: Analytics Tools & Frameworks , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions