SAP Knowledge Base Article - Public

3156632 - After upgrade some authorization checking not working in Manage Sales Order app - S/4HANA Cloud

Symptom

Sometimes after upgrade, the users restricted for one sales area/organization can find other sales orders from other sales area/organization.

Reproducing the Issue

  1.  Login Fiori launchpad and open app Manage Sales Order (F1873)
  2.  Search sales order and the user restricted for one sales area will be able to see all the sales orders .

Cause

Before upgrade, all the custom business roles are downloaded in advance and then are uploaded after upgrade.

During this period some inconsistency may be created and may cause the authorization issue.

Resolution

Make dummy change in the affected business role and save, which will refresh configuration table and resolve the authorization issue.

Keywords

KBA , SD-SLS-SO , Sales Orders , SD-SLS-SO-2CL , Sales Orders (Public Cloud) , BC-SRV-APS-IAM , Identity and Access Management , Problem

Product

SAP S/4HANA Cloud 2202