Symptom
Approval is not triggered when one of the line items in existing purchase order(PO) is canceled.
You have also set the Business configuration scoping question:Do you want to allow approval process for Purchase Order Cancellation?
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Purchase Requests and Orders work center
- Create a new purchase order with multiple line items
- Order the PO.
- The approval is triggered and once approval is completed, PO status becomes sent.
- Now cancel one of the line items in the order
- Send Update
- Purchase order approval is not triggered.
Cause
If you cancel at item level, then approval is not triggered. But if you cancel all the items, i.e. the PO is completely canceled, then it triggers approval.
Hence the scoping question: "Do you want to allow approval process for Purchase Order Cancellation?" works only at header level and not at item level at the moment.
Resolution
You can check with your PDI partner if they can create a custom approval for your business use-case.
OR
You can post this as a new requirement in the customer influence forum: https://influence.sap.com/sap/ino/#/campaign/886
This is our official channel to address all new requirements. If multiple customers vote for the same idea, our development team will check the feasibility of implementing this functionality in future.You can track the idea and check the status of the idea in that forum.
Keywords
Do you want to allow approval process for Purchase Order Cancellation, purchase order cancellation, approval not triggered for PO item cancellation, PO item cancellation , KBA , approval for purchase order cancellation , approval not triggered for item cancel , po item cancellation , AP-POP-PO , Purchase Order , Problem