Symptom
The cellPhone field is marked as required by default in the DCF and this cannot be changed in the DCF configuration.
How can the attribute of the field be changed?
Environment
SAP SuccessFactors Recruiting Marketing
Cause
RMK uses the Odata API entity CandidateLight to set the attribute of the field in the Data Capture Form, not the Candidate entity (which reflects the Candidate Profile template configuration)
If the attribute is set to Required True then the field will always be required by Default in the DCF and this won't be configurable in the DCF.
If it is set to Required False then the field will not be required by default and can be set to required manually in the DCF configuration.
Resolution
The cellPhone field is required or not in CandidateLight depending on whether the option Check country/region code and phone number in Manage Duplicate Candidates (Admin Center) is enabled or not.
To Disable or Enable the 'Country Code' and 'Phone Numbers' fields from the inital candidate creation page:
- Go to Admin Center
- Manage Duplicate Candidates
- Advanced Options
- Under Enforce additional candidate profile duplicity check upon candidate profile creation
- Enable/Disable Check country code and phone number
See Also
2832522 - Enabling Country Code & Phone Number from Candidate Creation Page - Recruiting - SAP for Me
Keywords
KBA , LOD-SF-RMK-CRM , Data Capture Form, Email Layout, Email Campaign , How To