Symptom
When editing username on the Employee Profile - error when saving "changes to your data cannot be saved"
Environment
SAP SuccessFactors HXM Suite
Reproducing the Issue
- Issue only applies to customers with the username field on the employee profile
- Where users have permission to view and edit username
- This is only one possible cause
Go to the employee profile of the user you want to update the username
Edit and set the new username value
Save - error is displayed "changes to your data cannot be saved"
Cause
- We recommend you use the Employee Import tool to update usernames
- However it can be possible to update the username on the employee profile if the field is enabled and available on the profile and your user has permissions to view and edit the profile
- Problems can arise if you are updating usernames on the profile, changes made directly on the profile can error for a number of reasons as the errors are not clearly defined so it can be hard to know why the change failed to save.
- One possible cause of the error "changes to your data cannot be saved" can be due to a manager/2nd manager cycle issue
Fore more information please see KBA - Manager Cycle
Resolution
The user you are trying to update the username for on Employee Profile but receiving an error "changes to your data cannot be saved"
Review the subject user, manager hierarchy (this can be any manager or 2nd manager about the user)
The users manager must be active and valid and each manager in the hierarchy above needs to be active and valid. If there is any issue with the manager hierarchy it can cause this error when updating the username directly on the profile.
Note: This is just one possible cause of the error. We do recommend you use the Employee Import to update usernames.
Keywords
Username Employee profile edit username update username changes to your data cannot be saved , KBA , LOD-SF-PLT-UIM , Employee Import Issues , Problem