Symptom
- There are cases where customers may have test tickets which are not needed
- Customers want to delete, remove or hide such unwanted tickets
- What is the most effective way of removing unwanted tickets
- How can one safely remove or delete test or unwanted ticket in production systems
Environment
- SAP C4C
- SAP Cloud for Customer
- SAP Cloud for Service
Cause
- By design, users are not permitted to delete tickets from any production systems (see Tickets FAQ)
- In both production systems and test systems:
- changing status of a ticket which status is/was set as "Closed" or "Completed" is not permitted or possible
- deleting a ticket that has a status of "Closed" or "Completed" is also not permitted or possible
- For tickets with other statuses, there are possible workarounds
Resolution
- Removing unwanted tickets in Non-Productive systems (Only)
- Logon C4C as an Administrator
- Navigate to Administrator > Service and Social > Ticket Configuration -> click "Delete Ticket"
- Only available in Test/QA systems
- This option is not available in any Production system (see KBA 2855569)
- Only one ticket can be deleted at a time
- Removing tickets in Production systems. Can only be done for tickets with statuses other than "Closed" or "Completed"
- Set the tickets to "Irrelevant" - hides the tickets from the Agents Queues (see "Managing the Ticket List" for more details)
- Select the ticket from the OWL
- Select "More" or the 3 dots at the upper right-hand corner (...)
- Select Set as "Irrelevant"
- Alternatively, one can also use the following steps to set the tickets as to be deleted (only works for tickets with status "Open"). See KBA 3088875 for more info.
- Search for the Business Object "Service Request" and download the excel file.
- Go to the Data Workbench, select the Export view
- Open the file, set the Ticket ID with the Ticket that you want to delete and add a Column named "TobeDeleted" and add the value as TRUE
- Go to the Data Workbench, select the Import view and upload the excel file that you have edited.
- Once the processing is complete, the Ticket is going to be deleted in definitive from the system
- the above can be validated via Administrator -> General Settings -> Deleted Data
See Also
- Status Handling in Tickets
- Scope and Configure Tickets
- Tickets FAQ
- 3088875 - How to Delete Tickets using Data Workbench
- 2855569 - "Delete Ticket" feature not available under Ticket Configuration settings
Keywords
Delete, deleting tickets, cloud for service, removing, hiding, remove, hide, deletion, C4C, , KBA , c4c , delete tickets , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications 2202