Symptom
Wrong currency visible to the user in the YTD revenue field.
Environment
SAP Cloud For Customer
Reproducing the Issue
Prerequisite: - Logged in user, is assigned to Organization Unit which has the currency maintained as EUR.
- Go to the Customers work center.
- Select Accounts Work Center View.
- Open the Account XXXXXX (where XXXXXX represents Account ID).
- The currency of the field YTD Revenue on the header level is shown in USD.
Cause
Logged in user is assigned to Organization Unit with holds currency EUR, however Company to which the organization is assigned, does not have the currency maintained.
Hence YTD revenue currency in account overview is defaulted to USD.
Resolution
Currency in Activity Pipeline and YTD Revenue fields on the header level of Account is determined in the following way:
- YTD Currency is picked from the company, to which logged in user is assigned to.
- YTD revenue currency is defaulted to USD, incase no currency is maintained in Company details.
Keywords
YTD Revenue, Currency determination, Wrong Currency, USD, EUR , KBA , LOD-CRM-OPP , Opportunity Management , Problem