Symptom
- User cannot save the email template after adding multiple users in Explicit Recipient Builder
- code" : "COE_PROPERTY_EXCEED_MAX_LENGTH", "message" : {
"lang" : "en-US", "value" : "Maximum length limit exceeded for field toRecipientsBuilderArgs: actual length: 284; maximum length: 255." - An error occurred while saving the email template. Please try again later or contact your system administrator.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Navigate to Email Services
- Active Templates
- Find the affected email template
- Click on it to edit
- Navigate past step two and three
- Select Explicit Recipient Builder from the To Recipient Builder
- Enter rows of users and emails that exceeds 255 Characters
- following error appears
- An error occurred while saving the email template. Please try again later or contact your system administrator.
Cause
The number of characters in the name and email exceeds 255
Resolution
- Navigate to Configure Object Definition
- Object Definition > EmailTemplate
- Take Action > Make Correction
- Find toRecipientsBuilderArgs > Click Details
- Change Maximum Length to 400 or greater
- Click Done > Click Save at the bottom
- Perform OData API Metadata Refresh And Export
- Add the rest of the users to recipient list
Keywords
Explicit Recipient Builder, Manage Onboarding Dynamic Groups, Maximum length limit exceeded for field toRecipientsBuilderArgs: actual length:, Email Template, Email, services , KBA , LOD-SF-OBX-EML , Notifications , Problem
Product
SAP SuccessFactors Onboarding