SAP Knowledge Base Article - Public

3157737 - Can't save email template after adding recipients using "Explicit Recipient Builder" - Onboarding

Symptom

  1. User cannot save the email template after adding multiple users in Explicit Recipient Builder
  2. code" : "COE_PROPERTY_EXCEED_MAX_LENGTH", "message" : {
    "lang" : "en-US", "value" : "Maximum length limit exceeded for field toRecipientsBuilderArgs: actual length: 284; maximum length: 255."
  3. An error occurred while saving the email template. Please try again later or contact your system administrator.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to Email Services
  2. Active Templates
  3. Find the affected email template
  4. Click on it to edit 
  5. Navigate past step two and three
  6. Select Explicit Recipient Builder from the To Recipient Builder
  7. Enter rows of users and emails that exceeds 255 Characters
  8. following error appears
  9. An error occurred while saving the email template. Please try again later or contact your system administrator.

Cause

The number of characters in the name and email exceeds 255

Resolution

  1. Navigate to Configure Object Definition
  2. Object Definition > EmailTemplate 
  3. Take Action > Make Correction
  4. Find toRecipientsBuilderArgs > Click Details
  5. Change Maximum Length to 400 or greater
  6. Click Done > Click Save at the bottom
  7. Perform OData API Metadata Refresh And Export
  8. Add the rest of the users to recipient list

Keywords

Explicit Recipient Builder, Manage Onboarding Dynamic Groups, Maximum length limit exceeded for field toRecipientsBuilderArgs: actual length:, Email Template, Email, services , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding