SAP Knowledge Base Article - Public

3158207 - Last Run Time field not getting updated automatically - Integration Center

Symptom

An Integration Center (IC) job is scheduled to run daily/weekly/monthly, but the Last Run Time field (under Filter and Sort > Time-Based Filters tabs) is not getting updated automatically with the last execution times.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors HXM Suite

Reproducing the Issue

  1. Create an IC job and set its scheduling (under Scheduling tab);
  2. After some execution, note that the Last Run Time field (under Filter and Sort > Time-Based Filters tabs) is not according the last execution time;

Cause

This happens when the latest job version wasn't scheduled.

In this case, an older job version is running by scheduling and Last Run Time field is being updated there only.

See the example below:

Resolution

Open the scheduled older version to see Last Run Time field correctly updated (under IC first page > My Integrations > clock icon).

If you wish, you can schedule the latest version as well (under Review and Run > Set Schedule).

Keywords

last, latest, run, runtime, execution, scheduling, IC, job, don't, do not, doesn't, does not, update, updating, automate, time-based, filter , KBA , LOD-SF-INT-INC-FWK , Integration Center UI Framework , LOD-SF-INT , Integrations , LOD-SF-INT-INC , Integration Center , Problem

Product

SAP SuccessFactors HCM suite all versions