Symptom
When a candidate is trying to log into the career site, CAPTCHA is still displaying for them although CAPTCHA has been disabled in the instance.
Environment
SAP SuccessFactors Recruiting Management
Cause
"Enable CAPTCHA on the External Career Site for Account Login" in Manage Recruiting Settings is ticked, which means it is enabled.
Resolution
The usage of CAPTCHA in the account creation and upon the login and password reset pages are treated separately in the system: there is a checkbox for account login and password reset, "Enable CAPTCHA on the External Career Site for Account Login", and another checkbox for account creation, "Disable CAPTCHA on the External Career Site for Account Creation" (and this option is also available in Provisioning > Company Settings).
So, when CAPTCHA displays in the login and/or password reset pages, that is due to the checkbox "Enable CAPTCHA on the External Career Site for Account Login" being enabled in the system.
To remove CAPTCHA from login/password reset pages as well, it will be required to do the following:
- Log into the instance
- Go to Admin Center
- Go to Manage Recruiting Settings
- Search by "Enable CAPTCHA on the External Career Site for Account Login"
- Uncheck the checkbox so it is disabled
Keywords
captcha, chinese, locale, career, site, candidate, rmk, account, login, password, reset. , KBA , LOD-SF-RCM-POR , Career and Agency Portals , Problem