SAP Knowledge Base Article - Public

3158983 - Error Message Z10 is Not a Valid Value for this Field. Enter a Valid Value when Adding a New Status in Status Dictionary or Status Schema

Symptom

You notice that, when adding a custom status in your Status Dictionary or Status Schema, the error message Z10 is Not a Valid Value for this Field. Enter a Valid Value is displayed.

This is not exclusively experienced when adding a Z status, as it can happen to Y status as well.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Navigate to Business Configuration work center.
  2. Navigate to Overview work center view.
  3. Search for Tickets.
  4. Open the activity Tickets for Customer Support or Tickets for Employee Support, depending on your scenario.
  5. Click Maintain Status Dictionary Entries.
  6. Click Add Row.
  7. Try adding a new status with code Z10.
  8. Add the Life Cycle Status and Assignment Status.
  9. See the error.

Cause

The Status Dictionary and Status Schema at the moment allow only statuses with 2 characters, meaning, you can go from Z1 up to Z9 and from Y1 up to Y9.

As Z10 or Y10 represents 3 characters, these are not supported.

Resolution

This is the system designed behavior.

Keywords

Status, Status Dictionary, Status Schema, Tickets, Tickets for Customer Support, Tickets for Employee Support, Z10, Y10, Z10 is Not a Valid Value for this Field. Enter a Valid Value, Y10 is Not a Valid Value for this Field. Enter a Valid Value, Valid, Value, Field, Error, Message, Error Message, , KBA , LOD-CRM-SRP , Service Request Processing , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions