SAP Knowledge Base Article - Public

3161463 - Is MongoDB version 4.0 supported for Workflow Accelerator

Symptom


Is it possible to use MongoDB version 4.x. for Signavio Workflow Accelerator? If not, will Signavio work on it?

javaEffektif.log true



Resolution


Please check the version of the MongoDB, for example:

bashMongoDB Version example in the case the used version of Mongodb is 4.0.12


Next, please review the version of Signavio Workflow Accelerator.


The Workflow Accelerator versions below 3.99 still using some functions that have been removed in MongoDB 4.0, that currently prevents support.

For more information, please see: Updating to Signavio Workflow Accelerator 3.56

If you wish to use MongoDB 4.0, then Workflow Accelerator v3.99 or above needs to be installed.

Updating to Signavio Workflow Accelerator 3.99


The solution is too either:

Downgrade MongoDB to a version that is compatible with the version of Signavio Workflow Accelerator

or

Upgrade to a version Signavio Workflow Accelerator that is compatible with the version of MongoDB (as per the above links).



Keywords

KBA , BPI-SIG-PM-ONP-DB , Database configuration for SAP Signavio Process Manager , How To

Product

SAP Signavio Process Governance all versions ; Workflow Accelerator by Signavio all versions