Symptom
Requested Date isn't replicated to all Products when copying a Sales Order.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Sales Workcenter.
- Go to Sales Order view.
- Search for any Sales Order.
- In the OWL, select the Order.
- Click "More".
- Click "Copy".
- In the Quick Creation view, change the “Requested date”.
- Add Products to the Sales Order (if not added already).
- Click "Save and Open".
- Go to Products facet.
- You can see that the Requested Date at header is only replicated in the first item.
Cause
The Requested Date at header is only copied to those items whose Requested Date is not manually changed.
You can test this by creating a new order, adding multiple items and, after that, if you change the Requested Date at the header, the Requested Date will change for all the Items.
However, if you make any manual change to the Requested Date at the item level, the changes made at header level to Requested Date will not be reflected in changed Items.
Resolution
The behaviour of requested date is that if the header and item requested dates are not the same, then the subsequent changes to the header requested date do not affect the item requested date.
If the changes at header requested date to affect the item requested date, then first should change the item requested date to header requested date. After this any changed made to header requested date will change the item requested date.
Keywords
Copy ; Order ; Replicated ; Item ; Product ; Requested Date ; Field , KBA , LOD-LE-CQP-CO , Lean Sales Orders , How To