SAP Knowledge Base Article - Public

3164385 - Unable to Integrate CTI Live Activity with Multiple CTI Vendors for concurrent use

Symptom

You notice that it is not possible to integration CTI / Live Activity with multiple CTI vendors at the same time when using SAP Cloud for Customer system.

Environment

  • SAP Cloud for Customer
  • SAP Service Cloud

Cause

At the moment, SAP Cloud for Customer only allows the connection to a single CTI vendor at a time, as the Live Activity configuration only accepts one setup by default.

Resolution

  • At present, the Live Activity implementation does not have the capability to support multiple concurrent CTI connections.
  • Possible workaround/alternative
    1. Use the "CTI_WIDGET_URL" to assign users a particular CTI connection based custom logic.
      • See "Support for Multiple CTI Vendors" for further details.
      • Note that this option will assign only one connection to the user, since this BAdI is triggered only once, when the user logs in. 
    2. If you are a partner: please use cloudsolutionpartner@sap.com or the Partnerfinder
    3. If you are a customer:
    4. Check the SAP Cloud for Customer Customer Influence to submit an idea - see SAP Service Cloud

Keywords

Service, CTI, Live Activity, Multiple Vendor, Vendor, CTI Vendor, Integrate, Integration, Unable, C4C, Cloud for Customer, Multiple, , KBA , LOD-CRM-LA , Live Activity , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications all versions