Symptom
- When trying to Create and Submit and E-verify, the following error appears "E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case."
- Try to Refresh Data for an E-Verify Process and receives the error: 'EV_DATA_ERROR: Incorrect data was provided'.
- The New hire enters the USCIS A-number (from the front of the card) in section 1 and the validator enters the IOE number in section 2 (from the back of the card). Section 2 is completed, but when the system tries to run E-Verify, error message is displayed: E-Verify encountered data errors. Please Contact Product Support with the following error details: alien_number: Invalid value for "alien_number", alien_number is required.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Access Candidate Dashboard
- Click on "Start" E-verify Create and Submit
- Review the data on the candidate's record
- Click on Submit
- Error Appears
Cause
This error can have many cause. Two of them is highlighted in this KBA:
CAUSE 1: The Alien Number is in an incorrect format.
- Error from Console: message":"alien_number: Invalid value for \"alien_number\", the character length must be smaller than or equal to 10."
CAUSE 2: E-Verify Case is missing in the MDF Object.
- Error from Console: message":"Cannot recognize parameter caseNumber"
Resolution
In order to review if the issue is related to Alien Number or missing Case Number, and fix this, please follow these steps:
- Before clicking on "Submit Case" or "Resolve Case" button press F12 to open the Developer Tools page
- Then click on "Submit Case" ir 'Resolve Case" button
- Under Network tab select $batch event
- See error message
- The error that appear will be similar to this:
- For Alien Number: {"error":{"code":"InternalError","message":"EV_DATA_ERROR: Incorrect data was provided","details":[{"code":"COE0019","message":"EV_DATA_ERROR: Incorrect data was provided"},{"code":"COE0019","message":"alien_number: Invalid value for \"alien_number\", the character length must be smaller than or equal to 10."},{"code":"COE0019","message":"alien_number: Invalid value for \"alien_number\", must conform to the pattern /^A\\d\{9\}$/."},{"code":"COE0019","message":"reason_for_delay_description: Invalid value for \"reason_for_delay_description\", the character length must be greater than or equal to 1."}]}}
- For Missing Case Number: {"error":{"code":"InternalError","message":"Cannot recognize parameter caseNumber","details":[{"code":"COE0018","message":"Cannot recognize parameter caseNumber"}]}}
- For Alien Number: {"error":{"code":"InternalError","message":"EV_DATA_ERROR: Incorrect data was provided","details":[{"code":"COE0019","message":"EV_DATA_ERROR: Incorrect data was provided"},{"code":"COE0019","message":"alien_number: Invalid value for \"alien_number\", the character length must be smaller than or equal to 10."},{"code":"COE0019","message":"alien_number: Invalid value for \"alien_number\", must conform to the pattern /^A\\d\{9\}$/."},{"code":"COE0019","message":"reason_for_delay_description: Invalid value for \"reason_for_delay_description\", the character length must be greater than or equal to 1."}]}}
FIX: Follow the below steps:
- Get the affected candidate's Compliance Process ID (You can get this at the end of the URL when you click 'View Case Details' from the onboarding dashboard).
- Next, navigate to Manage Data > Compliance Process
- Search for the affected candidates.
- Click the Quick Card beside the E-verify Data
SOLUTION 1: Check if the Alien number has the correct format. It should be A123456789.
More information about alien number: Immigrant Fee Payment: Tips on Finding Your A-Number and DOS Case ID | USCIS
SOLUTION 2:
- Check if 'Case Number' field is empty. If so, please raise a support ticket so the support team can ask their DHS Admin to gather the candidate's Case Number from the DHS site.
- Once the Case Number has been obtained, follow the steps 1 to 4 mentioned above.
- Then, add the Everify Case Number provided by the support's DHS Admin.
- Once done, Refresh Data from the onboarding dashboard->View E-Verify Details.
See Also
Keywords
EVF, DHS, submit, I9, AlienNumber, E-Verify, Case Number, Cannot recognize parameter caseNumber, OBX, ONB2.0, Onboarding, E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case, EV_DATA_ERROR: Incorrect data was provided, E-Verify encountered data errors. Please Contact Product Support with the following error details: alien_number: Invalid value for "alien_number", alien_number is required , KBA , LOD-SF-OBX-EVF , Everify , Problem