Symptom
- 'We are unable to find the data required to build a query. For assistance, please contact your SAP Product Support team, if needed.'
- 'We couldn't connect to your HANA system. For more information, see our troubleshooting page.'
- 'Please allow popups for this site to enable your live data connection'
- 'Pop-ups blocked:' pop up showing up in the browser
Environment
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Login to the instance
- Navigate to Reporting
- Create a new Story report
- Error with pop-up appears
Cause
There was an update implemented for all SF tenants in October which would enable certain flags for People Analytics. Due to some inconsistencies in the model, it was never triggered for the affected instance.
Resolution
If you encounter the same scenario in your tenant, please reach out to the support team. Then we will reach out to the Engineering team to enable the necessary flags for the affected instance which will resolve the issue.
If we see a 'Pop-ups blocked:' window in the browser, then as a work-around we can click on 'Always allow pop ups and redirects to:' and 'Done' in the browser pop up, however it will only solve the issue temporarily.
Note: This KBA is only for scenario where there is a pop-up showing up in the browser along with the error message.
Keywords
'Please allow popups for this site to enable your live data connection', 'We are unable to find the data required to build a query. For assistance, please contact your SAP Product Support team, if needed.', 'Pop-ups blocked:', error, Story report, People Analytics, trigger flags, inconsistencies, model, 'Always allow pop ups and redirects to:', browser, pop up, 'We couldn't connect to your HANA system. For more information, see our troubleshooting page.' , KBA , LOD-SF-ANA-SAC-ADM , SF Admin configurations (Security Center, Provisioning) , Problem