Symptom
You are using Odata Service Explorer to create a new Product Category, however you receive the error message "Product Category does not exist"
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to Administrator work center.
2. Click on OData Service Explorer.
3. Select c4odataapi and click on Test.
4. Go to Test tab and paste the URL.
5. Select POST and on XML tab paste your script.
6. Click on Test.
7. Error message appears: "Product Category does not exist"
Cause
The product category you are trying to create has a blank space as first character.
The UI cannot deal with leading blank character.
Resolution
You need to remove the blank space or create it as new without the blank space.
Keywords
Product, Category, Exist, OData, POST, Error , KBA , LOD-LE-PRD , Product + Product Category , How To