Symptom
When accessing the Offer Approval, the user is getting the error message "You're not authorized to view this offer approval" despite of the correct permissions.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
Scenario 1 - As the offer approval originator:
- Go to Job Requisition
- Click on the candidate in offer status
- Click Take Action > Offer > Offer Approval
- You are redirected to a new page with the error message: "You're not authorized to view this offer approval"
Pre-requisites: The user has the permission in the Job Requisition template to launch the offer approval in that particular status. They also have the "Permission to create forms" RBP for at least one offer approval template.
Scenario 2 - As the approver:
- Go to Home Page
- In the Approvals section, open the Job Offer todo card
- You are redirected to a new page with the error message: "You're not authorized to view this offer approval"
Cause
Cause 1: The user is part of a cycled manager relationship.
Run the 'UserWithoutManagerCycle' check for the User (logged in User), Manager and Manger’s Managers.
- Navigate to Check Tool.
- Select the 'Validation' tab.
- In the 'Application' dropdown, select 'User Management'.
- In the 'Area' dropdown, select 'User Hierarchy'.
- Click the 'Go' button.
- From the list, select 'No manager cycle exists for the user. (UserWithoutManagerCycle)'.
- Click the 'Run Check' button.
- In the 'Check Parameters' screen, select the user to run the check.
- Click the 'Run' button.
- Review the issues found.
Cause 2: The user has concurrent employments, and the secondary employment has been selected for approval.
Use Reporting or Integration Center to validate the Approver's User ID. The User ID for the secondary employment will be in the format "xxxxx-1".
- Report field: Offer Detail > Approver’s User ID
- OData API field: JobOfferApprover entity> offerApproverId
Cause 3: The user has an invalid Manager or Manager Hierarchy (Top Manager).
Step 1 Run the 'UserWithExistingActiveManager' check for the User (logged in User), Manager and Manger’s Managers.
- Navigate to Check Tool.
- Select the 'Validation' tab.
- In the 'Application' dropdown, select 'User Management'.
- In the 'Area' dropdown, select 'User Hierarchy'.
- Click the 'Go' button.
- From the list, select 'The user has an existing and active manager. (UserWithExistingActiveManager)'.
- Click the 'Run Check' button.
- In the 'Check Parameters' screen, select the user to run the check.
- Click the 'Run' button.
- Review the issues found.
Step 2 Use the Data Inspector tool to review the Manager.
- Navigate to Data Inspector.
- Select 'Table_USERS_SYSINFO'.
- Click the 'Add Filter Criteria' button.
- Select 'Users Sys ID' + 'Equals' + Enter the Users Sys ID of the user who returned the error in the check tool.
- Click the 'Show Data' button.
- Check the Manager field to verify if the manager exists and is active.
Resolution
For Cause 1 - Manager Cycle:
- Go to Admin Center > Employee Export > Export the file > Save the file
- Go to Admin Center > Import Employee Data > Select the file and "Validate File"
Please note that the system will show the issue(s) with Manager Cycle, so please correct them.
For Cause 2 - Secondary Employment:
If the assignment was correct, the approver should go to the secondary employment account (using Employment Switcher or Proxy) to process the offer approval.
If the assignment was wrong, use the 'Reassign Offer Approvals' tool to reassign the pending approval from the secondary employment account to the correct account.
For Cause 3 - Invalid Manager or Manager Hierarchy (Top Manager):
Please correct the data for the user who has an invalid manager or manager hierarchy. Change it into 'NO_MANAGER' if this user is the top manager in the hierarchy.
You can import the UDF to change the manager data to make it effective immediately or you may need to wait for a few minutes (if change that from UI) before the data works (less than 30 minutes, depends on LnR job).
See Also
For the Employee - Manager Relation Hierarchy:
- KBA 2227861 - Employee-Manager Relationship Not Reflected in Org Chart - Common Configuration Issues
- KBA 2344769 - Manager cycle detected message
For the Concurrent Employment and Global Assignment:
- KBA 2560602 - How to Switch between Employment Profiles like Concurrent Employment and Global Assignment
For how to report on Offer Approvers:
Keywords
RCM, offer detail template, restricted, no access, permission, issues, authorization, Offer Approval, Error, You're not authorized to view this offer approval , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem