Symptom
You have scheduled a Workflow Rule to execute many times until a condition is changed, however, you noticed the Workflow executed three times only.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Administrator Work Center.
- Go to Workflow Rules.
- Create a Workflow Rule with timing Scheduled.
- Set an event and condition that will trigger the Workflow in loop.
- The Workflow rule will execute three times and then stop.
Cause
This behavior is intentional and implemented to prevent an infinite loop, which could potentially compromise the stability of the background job infrastructure.
Resolution
This is the system design behavior of SAP Cloud for Customer.
If the feature/functionality is needed as a matter of urgency, please refer to KBA 3475641 - Functionality Currently not Available.
Keywords
workflow; rule; workflow rule; scheduled; three times; three; time; times; failed; execute; executed; triggered; , KBA , LOD-CRM-SRP , Service Request Processing , LOD-CRM-WKF , Workflow , How To