Symptom
User get an error message while trying to complete E-Verify for a candidate; E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case.
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Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Access the instance as Hiring Manager
- Click on Complete E-Verify tile
- Search for the candidate
- Click F12 or select Developer Tools
- Click start
- Error message is displayed: E-Verify Unavailable. E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case.
- At Developer Tools, you are going to search for the $batch event under the Network tab. The Response is going to display the following message: {"error":{"code":"InternalError","message":"EV_UNAUTHORIZED: Failed to authenticate in EVerify web service","details":[{"code":"COE0019","message":"EV_UNAUTHORIZED: Failed to authenticate in EVerify web service"},{"code":"COE0019","message":"INVALID_CLIENT_COMPANY_AUTHORIZATION: Unauthorized to perform case operation for client company."}]}}
Cause
- There is not Client ID valid under SuccessFactors in E-Verify site
- If your company needs to enroll in E-Verify with SuccessFactors as the employer agent, a new Memorandum of Understanding (MOU) should be created.
Resolution
- Request a new MOU through SuccessFactors
- Please follow this KBA 2421435
Keywords
On boarding, SuccessFactors, OBX , KBA , LOD-SF-OBX-EVF , Everify , Problem
Product
SAP SuccessFactors Onboarding all versions