SAP Knowledge Base Article - Public

3167299 - Getting error while creating E-Verify and submit case in Onboarding

Symptom

User get an error message while trying to complete E-Verify for a candidate; E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

SAP SuccessFactors Onboarding 

Reproducing the Issue

  1. Access the instance as Hiring Manager 
  2. Click on Complete E-Verify tile 
  3. Search for the candidate
  4. Click F12 or select Developer Tools
  5. Click start 
  6. Error message is displayed: E-Verify Unavailable. E-Verify did not receive your case information. Please try to resubmit the case or try again later by going to the E-Verify To-Do tile, find the new hire, and click Start to retrigger the E-Verify case.
  7. At Developer Tools, you are going to search for the $batch event under the Network tab. The Response is going to display the following message: {"error":{"code":"InternalError","message":"EV_UNAUTHORIZED: Failed to authenticate in EVerify web service","details":[{"code":"COE0019","message":"EV_UNAUTHORIZED: Failed to authenticate in EVerify web service"},{"code":"COE0019","message":"INVALID_CLIENT_COMPANY_AUTHORIZATION: Unauthorized to perform case operation for client company."}]}}

Cause

  • There is not Client ID valid under SuccessFactors in E-Verify site
  • If your company needs to enroll in E-Verify with SuccessFactors as the employer agent, a new Memorandum of Understanding (MOU) should be created.

Resolution

  • Request a new MOU through SuccessFactors 
  • Please follow this KBA 2421435

Keywords

On boarding, SuccessFactors, OBX , KBA , LOD-SF-OBX-EVF , Everify , Problem

Product

SAP SuccessFactors Onboarding all versions