SAP Knowledge Base Article - Public

3167643 - Profit Center for Service Order BAdI not working as expected

Symptom

serviceitem-profitcenter in BAdI CRMS4_SERV_CUST_I_MODIFY is not filled.

An extensibility field is created and filled with Profit Center for a service order. The field is then passed into a payload. In the payload, the field is blank.

Environment

  • Service Management (CRM)
  • SAP S/4HANA CE2208

Cause

The mapping of the Profit Center field to the extensibility field in the BAdI is not yet configured.

Resolution

The profit center field (serviceitem-profitcenter) will be available within CRMS4_SERV_CUST_I_MODIFY in the next release - CE2208.

Please note that this timeframe is not guaranteed. SAP may alter this planned release date without prior warning.

Keywords

CL_CRMS4_CLOUD_BADI_UTILITY, profit centre, SERVICE_ITEM_DATA, CL_CRMS4_ORDERADM_I_CONV, LS_SERVICEITEMS-PROFITCENTER, LS_ITEM_OB, center, logic, custom logic, business context, extend, extensibility, blank, empty, filled, order, SRV, Customer Service Manager, F3571A , KBA , CRM-S4-SRV-SVO , S4CRM: Service Order , CRM-S4-SRV-SVO-2CL , S4CRM: Service Order (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions