Symptom
During the Complete e-Signature step, when the onboardee clicks "Click to Sign", the system fails to capture the digital signature on the document template and triggers an application error with the message → "Looks like something went wrong!"
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Perform the Complete e-Signature task
- Open the document
- Click on "Click to Sign"
- Result(s): The system fails to capture the digital signature on the document template and triggers an application error with the message → "Looks like something went wrong!"
Cause
The error is caused by incorrect dimensions configured for the signature (DocuSignSignHere) and date (DocuSignDateSigned) fields in the document template.
Resolution
TROUBLESHOOTING:
Developer Tools > Network:
{
"error" : {
"code" : "ServerErrorException", "message" : {
"lang" : "en-US", "value" : "Cannot invoke \"org.apache.pdfbox.cos.COSArray.get(int)\" because \"fieldAreaArray\" is null"
}
}
}
SOLUTION:
- Reconfigure the document template by correcting the field dimensions for the signature and date fields as follows:
- Width: 52.92 mm
- Height: 7.76 mm
- Replace the existing document template by uploading the corrected version via Admin Center > Maintain Onboarding and Offboarding Document Templates.
- Restart the onboarding process for the affected onboardee to ensure the updated document is applied during the Complete e-Signature step.
Keywords
onboarding, complete, your, e-signature, click, to, sign, signature, not, working, looks, like, something, went, wrong, documents, signed, submit, fieldAreaArray, Cannot invoke \"org.apache.pdfbox.cos.COSArray.get(int)\" because \"fieldAreaArray\" is null , KBA , LOD-SF-OBX-DOC , Generation of Documents using PFS , Problem
Product
Attachments
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SAP Knowledge Base Article - Public