SAP Knowledge Base Article - Public

3168698 - Machine Learning Score is not available - where support user activated a model

Symptom

Machine Learning: ML Score is not available when a support user activated a model.

Environment

SAP CLoud for Customer

Reproducing the Issue

This can happen for several ML functions (Opp, Lead, Ticket, etc.)

Cause

The issue can be caused when the data-fetch during the batch scoring keeps failing because of an expired authorization token.

This can for example be happening because two score trigger jobs exist. One with a support user and another with customer's user (in obsolete state).

Ideally there should be only one trigger job.

The support user lifetime is short and gets locked after sometime. This might be causing the issue.

Resolution

If this is the case:

Please remove the trigger job generated out of support user context and then a customer user needs to activate the model again, so that the scoring trigger can happen in the unlocked user context.

Please activate the existing model again, so that it will get a correct job triggering user-context.

See Also

KBA 3002850 - Machine Learning: No Scoring for Opportunities Or Leads

Keywords

KBA , LOD-CRM-ML-SLS , Machine learning-sales cloud (cloud for customer) , Problem

Product

SAP Cloud for Customer core applications 2111