Symptom
- A custom party role created with a Party Category, such as 'Sales Owner Party,' cannot be added to the 'Involved Parties' facet on a lead or opportunity.
- This limitation affects the ability to assign custom roles directly within the 'Involved Parties' section.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite:
A custom party role with a Party Category, such as 'Sales Owner Party,' is created in the Business Configuration Fine Tuning Activity 'Party Role Definition.' This role is added to Leads or Opportunity Fine Tuning via 'Maintain Involved Parties' and activated.
- Navigate to the Sales work center.
- Search and open any Lead or Opportunity.
- Edit the selected Lead or Opportunity.
- Go to the 'Involved Parties' facet.
- Click on Edit.
- Click on Add.
- Observe that the custom party role, such as 'Sales Owner Party,' is not available in the options.
Cause
- Custom-defined roles, such as 'Sales Owner Party,' are not configured to appear in the 'Involved Parties' facet.
- These roles are only available in the 'Sales Team' facet of the Lead or Opportunity.
Resolution
Execute following steps for Customer party role to be available in opportunity or lead
- Search and open the relevant Lead or Opportunity.
- Navigate to the 'Sales Team' facet.
- Edit the Lead or Opportunity.
- Click on Add.
- Verify that the custom party role, such as 'Sales Owner Party,' is available in this section.
See Also
KBA 2625519 - Difference Between Owner And Owner Sales
Keywords
Customer party Role, Missing, role, owner sales, Involved parties, Lead, Opportunity, Sales Team , KBA , LOD-CRM-OPP , Opportunity Management , LOD-CRM-LM , Lead Management , How To
SAP Knowledge Base Article - Public