SAP Knowledge Base Article - Public

3168866 - Lead Workflow Rule Does Not Work

Symptom

You created a Workflow Rule 123 (123 refers to rule ID), for Leads, with condition based on the change of the Owner field.

However, workflow rule is not triggered when the field is changed.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Administrator Workcenter, Workflow Rules view.
  2. Select Workflow Rule 123 and click to Edit.
  3. On conditions page, field Owner (Formatted Name) is being used.

Now, go to Lead ABC (ABC refers to the Lead ID):

  1. Change the Owner field, present on header.
  2. Go to the Workflow changes tab and see that the rule was not triggered.

Going back to Workflow Rules view, at Administrator WC, checking the rule log, you'll see that the rule was not triggered, indeed.

Cause

Option Owner (Formatted Name) is mapped to Created By field, not Owner field.

Resolution

If you want to use the field Owner as a condition, please use option Owner ID as condition.

See Also

    2562714 - Workflow Rule Not Working with Condition Before Object Change

Keywords

Workflow Rule, Leads, Owner , KBA , LOD-CRM-LM , Lead Management , How To

Product

SAP Cloud for Customer core applications 2202