SAP Knowledge Base Article - Public

3168869 - Candidate did not receive (ONB) External User Welcome Message Trigger email from the system - Onboarding

Symptom

Multiple (ONB) External User Welcome Message Trigger emails are configured in the system and none of these emails got triggered for the affected candidate.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Activate (ONB) External User Welcome Message Trigger emails;
  2. Initiated onboarding and completed New Hire Data Review step;
  3. Email not triggered for the candidate.

Cause

Cause 1:

Multiple templates for "(ONB) External User Welcome Message Trigger" enabled and in one of the templates recipient is not the new hire. As the recipient does not have email information maintained in the Employee Profile, hence the email message is resulting in error due to invalid recipient. As of now we have a limitation that if email message construction fails for any template, then email is not sent for other templates as well.

Cause 2:

The candidate's data does not meet the business rule conditions for email binding, so the email is skipped.

(For SAP Support, refer to the internal memo for the error logs.) 

Resolution

Resolution for Cause 1:

Make sure that all the recipients configured in the email templates have a valid email ID maintained in the Employee Profile under email information. For the new hire as well, a valid email must be maintained.

Resolution for Cause 2:

Note that the candidate's data needs to meet the conditions of the email business rules.

Keywords

welcome email, external email, email trigger failed, Recipient is resolved to null or empty, email skipped, candidate don't receive the email, email not trigger, email business rule , KBA , LOD-SF-OBX-EML , Notifications , Problem

Product

SAP SuccessFactors Onboarding all versions