SAP Knowledge Base Article - Public

3168869 - [Onboarding]Candidate did not receive (ONB) External User Welcome Message Trigger email from the system

Symptom

Multiple (ONB) External User Welcome Message Trigger emails are configured in the system and none of these emails got triggered for the affected candidate

Environment

SAP SuccessFactors Onboarding

Cause

Support Engineers kindly refer the internal memo for the error logs. As per the logs customer has multiple templates for "(ONB) External User Welcome Message Trigger" and in one of the templates recipient is not the new hire. As the recipient does not have email information maintained in the Employee Profile, hence the email message is resulting in error due to invalid recipient. As of now we have a limitation that if email message construction fails for any template, then email is not sent for other templates as well.

Resolution

Kindly make sure that all the recipients configured in the email templates have a valid email ID maintained in the Employee Profile under email information. For the new hire as well valid email must be maintained.

For the limitation of failure of all the other templates when a particular email fails there is an enhancement request in place. 

Keywords

email trigger failed, Recipient is resolved to null or empty , KBA , LOD-SF-OBX-EML , Notifications , Product Enhancement

Product

SAP SuccessFactors Onboarding 2111