Symptom
Customer does not receive VCAL/ICS via email when the click Resend Registration Email Notification in the Class Actions when it's a Virtual Class.
It's important to note that if the Class is not Virtual, system will send VCAL/ICS when re-sending the notification.
Environment
SAP SuccessFactors Learning
Reproducing the Issue
- Create a VLS Class >
- Enroll a test user that has the email address of the person testing the issue >
- Registration Email Notification received along with ICS (2 separated emails) >
- Go back to the VLS Class >
- Click on Actions >
- Click on: Resend Registration Email Notification >
- Only the Registration Email Notification received, no ICS. (1 Email and no ICS/VCAL).
Cause
This is not a defect and working as intended. It is a different flow when the admin selects the Resend Registration notification and if it is a Virtual class. If it is a virtual class, there is a check for anything that has changed, such as date or time and if so then an updated ICS/VCAL is sent out. In this case, if no change has occurred then no ICS/VCAL is sent out. So the process is different. If there was a change to date and time and no notification is sent out then we do have a defect.
Resolution
If it's desired to change the current system behavior, we strongly recommend that an Enhancement Request is created in our Innovation Portal. Please refer to this SAP Note for further details.
See Also
2090228 - How to Submit Ideas for SAP SuccessFactors Products
Keywords
Resend Notification, Resend Class notification, Resend VCAL, Resend ICS, VCAL, ICS , KBA , LOD-SF-LMS-NOT , Notifications , LOD-SF-LMS , Learning Management System , LOD-SF-LMS-SCH , Class - Scheduled Offerings , LOD-SF-LMS-VLS , Virtual Learning System , Product Enhancement